2019-06-24 23:21 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002143NetSurfRISC OS-specificpublic2015-03-10 11:06
ReporterHarriet Bazley 
Assigned ToVincent Sanders 
SeverityminorReproducibilityalways 
StatusclosedResolutionfixed 
PlatformARMOSRISC OSOS Version5.19
Product Version3.2 
Target VersionFixed in Version3.2 
Summary0002143: Lower part of page hidden/crash on fanfiction.net
DescriptionLoading the page https://www.fanfiction.net/r/7302546/ displays only the first few paragraphs of content, below which the window is blank.
Moreover subsequently attempting to edit the URL (in order to see if the mobile version of the site would render any better) causes a segmentation fault in the browser.
Steps To ReproduceDouble-click on URL in text file (or via web link).
Place input focus in URL bar and delete a couple of 'w's from "http://www...."
Browser crashes without return key being pressed (could this be associated with auto-complete?)
Additional InformationURL editing was fine as of Netsurf v.1932. Tried Netsurf v1963 but this crashes with the same symptoms as v1966.
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #1966
URL of problem pagehttps://www.fanfiction.net/r/7302546/
Attached Files
  • zip file icon Log.zip (6,761 bytes) 2014-06-10 21:37

-Relationships
+Relationships

-Notes
Harriet Bazley

~0000377

Harriet Bazley (reporter)

The URL-editing issue appears to be a generic problem with the current release which will cause any site to crash - hence rather more serious than I had assumed!
Vincent Sanders

~0000378

Vincent Sanders (administrator)

this is caused by idna_encode() in utils/idna.c:594

Breakpoint 1, idna_encode (host=0x7fffdc02eff0 ".fanfiction.net", len=15,
    ace_host=0x7fffffffce88, ace_len=0x7fffffffce80) at utils/idna.c:598
598 size_t label_len, output_len, ucs4_len, fqdn_len = 0;

when entered thusly the while loop immediately terminates due to idna__host_label_length() returning 0 and then decrements the pointer back off the front of the stack based char array and tries to duplicate the "string" followed by setting the output length to -1

this all ends very badly.
Vincent Sanders

~0000379

Vincent Sanders (administrator)

fixed idna en/de coder to not explode if the first part of host is missing
Vincent Sanders

~0000708

Vincent Sanders (administrator)

Confirmed fixed in 3.2 release
+Notes

-Issue History
Date Modified Username Field Change
2014-06-10 21:37 Harriet Bazley New Issue
2014-06-10 21:37 Harriet Bazley File Added: Log.zip
2014-06-10 21:45 Harriet Bazley Note Added: 0000377
2014-06-10 22:30 Vincent Sanders Status new => acknowledged
2014-06-10 22:30 Vincent Sanders Product Version 3.1 => 3.2
2014-06-10 22:30 Vincent Sanders Description Updated View Revisions
2014-06-10 22:30 Vincent Sanders Steps to Reproduce Updated View Revisions
2014-06-10 23:30 Vincent Sanders Note Added: 0000378
2014-06-10 23:30 Vincent Sanders Assigned To => Vincent Sanders
2014-06-10 23:44 Vincent Sanders Note Added: 0000379
2014-06-10 23:44 Vincent Sanders Status acknowledged => resolved
2014-06-10 23:44 Vincent Sanders Resolution open => fixed
2015-03-10 11:06 Vincent Sanders Note Added: 0000708
2015-03-10 11:06 Vincent Sanders Status resolved => closed
2015-03-10 11:06 Vincent Sanders Fixed in Version => 3.2
+Issue History