2019-03-26 21:18 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002127NetSurfABENDpublic2016-02-16 14:04
ReporterRichard Porter 
Assigned To 
SeveritycrashReproducibilitysometimes 
StatusclosedResolutionfixed 
PlatformRiscPCOSRISC OSOS Version4.16
Product Version3.2 
Target VersionFixed in Version3.4 
Summary0002127: Segfault on forum page
DescriptionNetsurf crashed with a segmentation fault when I requested the problem page from my local home page. It also crashed Messenger Pro at the same time, leaving MsgServe running.
Steps To ReproduceOpen local page containing the link to the forum.
Click Select on this link.
Additional InformationCrashed version 1855. Downloaded the latest version and it crashed again.
You can access the forum without registering.
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #1885
URL of problem pagehttp://www.minimarcos.org.uk/cgi-bin/forum/Blah.pl?b=,v=search,p=topten
Attached Files

-Relationships
+Relationships

-Notes
Richard Porter

~0000329

Richard Porter (reporter)

Reproducibility was always, causeing progressively more mayhem, until I rebooted, after which the page worked OK.
Dave Higton

~0001197

Dave Higton (developer)

Richard, can you try again with a current CI build, please? It works for me, BBxM, RO 5.22, CI #3349.

I'm guessing that neither of us will be able to reproduce it. If that's the case, I'll close it, because there's no point in keeping issues open that can't be reproduced.
Richard Porter

~0001202

Richard Porter (reporter)

I haven't had this particular situation since. In common with a lot of these random crashes if the log doesn't help you there isn't a lot I can add as I don't keep an audit log of all my keystrokes.
Vincent Sanders

~0001231

Vincent Sanders (administrator)

Confirmed fixed in 3.4 release
+Notes

-Issue History
Date Modified Username Field Change
2014-05-17 18:53 Richard Porter New Issue
2014-05-17 18:53 Richard Porter File Added: nslog297.zip
2014-05-17 19:08 Richard Porter Note Added: 0000329
2014-05-17 22:31 Vincent Sanders Status new => acknowledged
2014-05-17 22:31 Vincent Sanders Category RISC OS-specific => ABEND
2014-05-17 22:31 Vincent Sanders Product Version => 3.2
2014-05-17 22:31 Vincent Sanders Steps to Reproduce Updated View Revisions
2014-05-17 22:31 Vincent Sanders Additional Information Updated View Revisions
2016-02-05 22:28 Dave Higton Note Added: 0001197
2016-02-05 23:57 Richard Porter Note Added: 0001202
2016-02-06 19:56 Dave Higton Status acknowledged => resolved
2016-02-06 19:56 Dave Higton Resolution open => fixed
2016-02-06 19:56 Dave Higton Steps to Reproduce Updated View Revisions
2016-02-06 19:56 Dave Higton Additional Information Updated View Revisions
2016-02-16 14:04 Vincent Sanders Note Added: 0001231
2016-02-16 14:04 Vincent Sanders Status resolved => closed
2016-02-16 14:04 Vincent Sanders Fixed in Version => 3.4
2016-02-16 14:04 Vincent Sanders Steps to Reproduce Updated View Revisions
2016-02-16 14:04 Vincent Sanders Additional Information Updated View Revisions
+Issue History