2019-03-26 21:14 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002074NetSurf[All Projects] Generalpublic2015-03-10 11:13
Reporterszukw000 
Assigned ToVincent Sanders 
SeverityminorReproducibilityalways 
StatusclosedResolutionfixed 
PlatformOSlinuxOS Version3.13.0
Product Version3.0 
Target VersionFixed in Version3.2 
Summary0002074: Bugs and changes in 'netsurf-3.0-full-src.tar.gz'
DescriptionSome days ago I downloaded 'netsurf-3.0-full-src.tar.gz'.

I use

 linux-3.13.0
 bison (GNU Bison) 2.7
 flex 2.5.35
 gcc (GCC) 4.8.2

'make clean' does not work:
------------------------
make clean

rm -f -r netsurf-3.0-full/prefix-gtk
make distclean --directory=src/buildsystem-1.0 TARGET=gtk
make[1]: Entering directory `netsurf-3.0-full/src/buildsystem-1.0'
make[1]: *** No rule to make target `distclean'. Stop.
make[1]: Leaving directory `netsurf-3.0-full/src/buildsystem-1.0'
make: *** [clean] Error 2

------------------------

'make' fails because in:

 src/nsgenbind-0.0.1/build-Linux-gtk-release-binary/nsgenbind-lexer.c
 src/nsgenbind-0.0.1/build-Linux-gtk-release-binary/nsgenbind-lexer.h

 YYSTYPE is unknown
 YYLTYPE is unknown

and in:

 src/nsgenbind-0.0.1/build-Linux-gtk-release-binary/webidl-lexer.c
 src/nsgenbind-0.0.1/build-Linux-gtk-release-binary/webidl-lexer.h

 YYSTYPE is unknown
 YYLTYPE is unknown

I created (and included) a header file 'defs.h' for these types.
Perhaps you do know better how to solve this bug.

------------------------

The scroll value (UP,DOWN,LEFT,RIGHT) seemed to be 1 only. I
could not accept this and added/subtracted a '_SCROLL_STEP' in
'window.c' and 'treeview.c'. The value is defined in 'gui.h'.

In 'rsvg.c' I removed

#include <librsvg/rsvg-cairo.h>

because this header file shall not be included directly.

In 'mng.c' I added

#include <stdio.h>

because 'FILE' was unknown in 'jpeglib.h'.
By the way: 'stdio.h' is included in 'mng.c' of 'netsurf-2.9-full'.

winfried
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Vincent Sanders

~0000721

Vincent Sanders (administrator)

Confirmed fixed in 3.2 release
+Notes

-Issue History
Date Modified Username Field Change
2014-02-11 09:51 szukw000 New Issue
2014-02-11 09:51 szukw000 File Added: netsurf-3.0-full-src.dif.gz
2014-06-12 11:25 Vincent Sanders Project Buildsystem => NetSurf
2014-06-12 11:26 Vincent Sanders Status new => acknowledged
2014-06-12 11:26 Vincent Sanders Product Version => 3.0
2014-08-03 14:49 Vincent Sanders Assigned To => Vincent Sanders
2014-08-03 14:49 Vincent Sanders Status acknowledged => resolved
2014-08-03 14:49 Vincent Sanders Resolution open => fixed
2014-08-03 14:49 Vincent Sanders Fixed in Version => 3.2
2015-03-10 11:13 Vincent Sanders Note Added: 0000721
2015-03-10 11:13 Vincent Sanders Status resolved => closed
+Issue History