2019-01-16 17:30 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002067NetSurfRISC OS-specificpublic2015-03-10 11:01
ReporterBrian Jordan 
Assigned ToSteve Fryatt 
SeveritycrashReproducibilitysometimes 
StatusclosedResolutionfixed 
PlatformVirtual AcornOSRISC OSOS Version6.20
Product Version 
Target VersionFixed in Version3.1 
Summary0002067: Possible conflict between NetSurf and Mouseaxess
DescriptionMouseaxess provides a number of additional features axcessed via the mouse buttons. In particular holding down the "Menu" button when the pointer is in a window enables scrolling of that window. This appears to provoke a crash in NetSurf.
Steps To ReproduceLoad Mouseaxess, open any window in Netsurf and scroll vigourously using the "Menu" button, in about 1 of 10 attemptsNetSurf crashes.
Additional InformationThe attached zip file contains a log of one such event on this machine and three, reportedly similar, events from Richard Torrens. I don't have his platform, OS and NetSurf build details.
TagsNo tags attached.
Fixed in CI build #1781
Reported in CI build #1695
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Michael Drake

~0000185

Michael Drake (administrator)

Caused by failed assertion in RISC OS mouse handling:

"riscos/mouse.c", line 183: ro_mouse_track_start: Assertion failed: ro_mouse_poll_end_callback == NULL && ro_mouse_poll_track_callback == NULL && ro_mouse_poll_data == NULL
John-Mark Bell

~0000227

John-Mark Bell (administrator)

This implies that multiple Pointer Entering Window events are being sent to NetSurf without corresponding Pointer Leaving Window events in between.
John-Mark Bell

~0000228

John-Mark Bell (administrator)

Additionally, MouseAxess no longer has an online presence, so anyone wanting to debug this will need to have a copy of it already.
Brian Jordan

~0000235

Brian Jordan (reporter)

In the absence of an online presence for Mouseaxess, and noting that the help file says, inter alia, "MouseAxess is Freeware, and suitable for RISC OS computers only. You may use and copy it freely, as long as the application remains unchanged." I have placed an archive of it at www.clubmans.org.uk/netsurf/mousax.zip for what it may or not be worth.
Steve Fryatt

~0000295

Steve Fryatt (developer)

Reproduced on RISC OS 5/Iyonix, probably when MouseAxess and NetSurf both think they're the one dragging the window.

Resolved by allowing any existing mouse track to exit cleanly when a new one starts unexpectedly. This may have knock-on effects, so such events are reported in the NetSurf log just in case.
Vincent Sanders

~0000692

Vincent Sanders (administrator)

Confirmed fixed in 3.1 release
+Notes

-Issue History
Date Modified Username Field Change
2014-02-07 13:59 Brian Jordan New Issue
2014-02-07 13:59 Brian Jordan File Added: NetSLog.zip
2014-02-07 14:16 Michael Drake Note Added: 0000185
2014-02-07 14:16 Michael Drake Assigned To => Steve Fryatt
2014-02-07 14:16 Michael Drake Status new => acknowledged
2014-02-07 14:23 Michael Drake Severity minor => crash
2014-02-10 01:54 John-Mark Bell Note Added: 0000227
2014-02-10 02:16 John-Mark Bell Note Added: 0000228
2014-02-10 11:28 Brian Jordan Note Added: 0000235
2014-04-05 19:12 Steve Fryatt Fixed in CI build # => 1781
2014-04-05 19:12 Steve Fryatt Note Added: 0000295
2014-04-05 19:12 Steve Fryatt Status acknowledged => resolved
2014-04-05 19:12 Steve Fryatt Fixed in Version => 3.1
2014-04-05 19:12 Steve Fryatt Resolution open => fixed
2015-03-10 11:01 Vincent Sanders Note Added: 0000692
2015-03-10 11:01 Vincent Sanders Status resolved => closed
+Issue History