2019-08-19 03:25 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002061NetSurf[All Projects] Generalpublic2016-11-22 21:58
ReporterMichael Drake 
Assigned ToMichael Drake 
SeverityminorReproducibilityalways 
StatusclosedResolutionfixed 
PlatformRISC OSOSRISC OSOS Version5.20
Product Version3.0 
Target Version3.6Fixed in Version3.6 
Summary0002061: Favicon not shown correctly
DescriptionThe BBC favicon is not shown correctly. It looks like it's being rendered without a mask. In Firefox, the top and bottom of the bitmap are masked, but in NetSurf the full square is visible.

The bug occurs with the 16x16 version of the favicon.
Steps To ReproduceTo view as favicon:

 1. visit: http://www.bbc.co.uk/news/

or to view standalone:

 1. visit http://www.bbc.co.uk/favicon.ico
 2. Scale display down to 50%
Additional InformationThe scaling is because NetSurf chooses the highest resolution version of the ICO to display by default, and there is no problem displaying the 32x32 ICO. The Problem is with the 16x16 ICO which is displayed when you scale to 50%.

Same issue observed with RO and GTK NetSurf.
TagsNo tags attached.
Fixed in CI build #3677
Reported in CI build #1638
URL of problem pagehttp://www.bbc.co.uk/news/
Attached Files

-Relationships
+Relationships

-Notes
Vincent Sanders

~0001428

Vincent Sanders (administrator)

this issue has been closed because it is included in the 3.6 release
+Notes

-Issue History
Date Modified Username Field Change
2014-01-24 21:57 Michael Drake New Issue
2014-01-24 21:59 Michael Drake Reproducibility have not tried => always
2014-01-24 21:59 Michael Drake Additional Information Updated View Revisions
2014-01-25 11:39 Michael Drake Steps to Reproduce Updated View Revisions
2014-01-26 10:26 Vincent Sanders Status new => confirmed
2014-01-26 10:26 Vincent Sanders Description Updated View Revisions
2014-01-26 10:26 Vincent Sanders Steps to Reproduce Updated View Revisions
2014-01-26 10:26 Vincent Sanders Additional Information Updated View Revisions
2016-08-22 15:10 Michael Drake Fixed in CI build # => 3677
2016-08-22 15:10 Michael Drake Assigned To => Michael Drake
2016-08-22 15:10 Michael Drake Status confirmed => resolved
2016-08-22 15:10 Michael Drake Resolution open => fixed
2016-08-22 15:10 Michael Drake Fixed in Version => 3.6
2016-08-22 15:10 Michael Drake Target Version => 3.6
2016-11-22 21:58 Vincent Sanders Note Added: 0001428
2016-11-22 21:58 Vincent Sanders Status resolved => closed
+Issue History