2019-03-22 07:09 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002050NetSurf[All Projects] Generalpublic2015-03-10 10:38
ReporterEwen Pring 
Assigned ToVincent Sanders 
SeverityminorReproducibilityalways 
StatusclosedResolutionfixed 
PlatformOSRISC OSOS Version5.19
Product Version3.0 
Target VersionFixed in Version3.1 
Summary0002050: Form fields not submitted if hidden from display
DescriptionIf HTML form input fields are hidden using the CSS display:none property, those fields are not sent with the form when submitted (whether using a method of POST or GET). Other browsers seem to send them.
Steps To ReproduceSee test HTML enclosed. As provided, just press the submit button then examine the URL bar and you can see 'surname' and 'email' have been passed on, but not the 2 other hidden fields. Now alter the inline CSS in the HTML code from display:none to display:all and try again; the extra form fields 'booktype' and 'nopages' will now be seen, and on submitting their values will appear in the URL bar.
Additional InformationThis prevents a 'reverse captcha' on a web contact form of mine working with NetSurf. The writers of the script powering the form suggest using such hidden fields with predetermined values which, if not present (eg because spam bots are doing their worst), will cause the script to stop the attempted contact. It is likely there are quite a few similar contact forms out there on the web.
TagsNo tags attached.
Fixed in CI build #1595
Reported in CI build #1556
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Vincent Sanders

~0000664

Vincent Sanders (administrator)

Confirmed fixed in 3.1 release
+Notes

-Issue History
Date Modified Username Field Change
2014-01-01 01:21 Ewen Pring New Issue
2014-01-01 01:21 Ewen Pring File Added: form-piped-output.htm
2014-01-01 11:10 Vincent Sanders Severity major => minor
2014-01-01 11:10 Vincent Sanders Status new => acknowledged
2014-01-05 17:12 John-Mark Bell Fixed in CI build # => 1595
2014-01-05 17:12 John-Mark Bell Status acknowledged => resolved
2014-01-05 17:12 John-Mark Bell Resolution open => fixed
2014-01-05 17:12 John-Mark Bell Fixed in Version => 3.1
2015-03-10 10:38 Vincent Sanders Note Added: 0000664
2015-03-10 10:38 Vincent Sanders Status resolved => closed
2015-03-10 10:38 Vincent Sanders Assigned To => Vincent Sanders
+Issue History