2019-06-25 03:27 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001986NetSurfLayoutpublic2016-02-16 14:34
ReporterEwen Pring 
Assigned ToMichael Drake 
SeverityfeatureReproducibilityhave not tried 
StatusclosedResolutionfixed 
Product Version3.0 
Target Version3.4Fixed in Version3.4 
Summary0001986: CSS Overflow-y property
DescriptionCSS 3 introduced an overflow-y property. If NetSurf could support this then it would make it usable with, for example, Lloyds TSB business internet banking for me once again.

More info: at present when the Lloyds site gives a list (for example of account payees) the user can only see the top few entries and the rest is hidden with no way to see in the browser. The page is designed to show a vertical only scroll bar but Netsurf doesn't.

The reason for this is that the HTML (a simple example attached) for a limited size element (the list, eg 90 pixels high) uses the CSS 2 property overflow:hidden (thereby ensuring Netsurf shows no scroll bars when the content exceeds the area available) but also the CSS 3 property overflow-y:scroll (which is intended to put a scroll bar in vertically).

Web develpers have started doing this because before CSS 3 if they used overflow:auto then browsers would put in both horizontal and vertical scrollbars, whereas they prefer vertical only scrollbars, which they can now get with CSS 3.
Additional InformationImported from sourceforge bug http://sourceforge.net/support/tracker.php?aid=3419529 on Tue Dec 10 17:34:13 2013

TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Vincent Sanders

~0001263

Vincent Sanders (administrator)

Confirmed fixed in 3.4 release
+Notes

-Issue History
Date Modified Username Field Change
2013-12-10 17:41 Vincent Sanders New Issue
2013-12-10 17:41 Vincent Sanders Status new => assigned
2013-12-10 17:41 Vincent Sanders Assigned To => Sourceforge Import placeholder
2013-12-20 12:08 Vincent Sanders Assigned To Sourceforge Import placeholder =>
2013-12-20 12:08 Vincent Sanders Status assigned => confirmed
2013-12-20 12:08 Vincent Sanders Resolution no change required => open
2013-12-20 12:08 Vincent Sanders Category General => Layout
2013-12-20 12:08 Vincent Sanders Product Version => 3.0
2013-12-20 12:08 Vincent Sanders Description Updated View Revisions
2013-12-20 12:08 Vincent Sanders Additional Information Updated View Revisions
2015-11-01 14:41 Daniel Silverstone Assigned To => Michael Drake
2015-11-01 15:23 Michael Drake Status confirmed => resolved
2015-11-01 15:23 Michael Drake Resolution open => fixed
2015-11-01 15:35 Michael Drake Fixed in Version => 3.4
2015-11-01 15:35 Michael Drake Target Version => 3.4
2016-02-16 14:34 Vincent Sanders Note Added: 0001263
2016-02-16 14:34 Vincent Sanders Status resolved => closed
+Issue History