2019-01-22 02:56 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001970NetSurfRISC OS-specificpublic2016-02-16 15:30
ReporterTony Moore 
Assigned ToVincent Sanders 
SeverityfeatureReproducibilityN/A 
StatusclosedResolutionfixed 
Product Version1.0 
Target VersionFixed in Version3.4 
Summary0001970: full-save datestamps
DescriptionProblem:

A full-save application does not contain a !runimage so that, if the full-save is copied, the datestamp of the original full-save is lost. To determine when it was saved it is then necessary to open the full-save application and inspect the datestamp of the 'index' file.

Some months ago, this problem caused several hundred of my full-saves to be re-stamped with the date of installation of a new hard-drive.

Suggestion:

A full-save application should contain a !runimage, so that its datestamp will determine the datestamp of the full-save application. The !runimage could most usefully be a URL file, containing the URL of the page. See too my feature request 'full-save should also save the page url' at http://sourceforge.net/tracker/index.php?func=detail&aid=1365047&group_id=51719&atid=464315

Tony

Additional Informationold_coaster added a note on Wed Jul 11 22:50:36 2007

Logged In: YES
user_id=1384902
Originator: YES

A full-save pseudo-application now contains a URL file, giving its source url, so I would amend my suggestion, above, to read:

Suggestion:

A full-save pseudo-application should contain a !RunImage file, which could be of zero lenth, so that its datestamp would determine the datestamp of the full-save pseudo-application.


Imported from sourceforge bug http://sourceforge.net/support/tracker.php?aid=1594350 on Tue Dec 10 17:34:13 2013

TagsNo tags attached.
Fixed in CI build #2654
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Tony Moore

~0000196

Tony Moore (reporter)

My amended suggestion in 'Additional information' above, remains valid.

Tony
David Pitt

~0000774

David Pitt (reporter)

Last entry 2009! This just needs a decision, either do it or close it.
Vincent Sanders

~0000786

Vincent Sanders (administrator)

I just implemented creating a !RunImage file, hope thats right
Rob Kendrick

~0000793

Rob Kendrick (administrator)

I find this confusing. Application directories have their own time stamp, and this is displayed in the Filer's Info dialogue. I don't understand what the !RunImage has to do with anything.

Tony, can you expand on what you mean?
Tony Moore

~0000795

Tony Moore (reporter)

Last edited: 2015-03-18 10:35

View 2 revisions

@ Vincent: Many thanks. It works fine.

@ Rob: The reasoning was explained im my original Description, at the head of this page. In RISC OS, when a directory is copied, a new datestamp is assigned to it, which means that the original datestamp is lost. The suggested change, which Vincent has now implemented, ensures that the original datestamp of the full-save directory is preserved, because an application directory shows the datestamp of the !Runimage file, when present.

Vincent Sanders

~0001323

Vincent Sanders (administrator)

Confirmed resolved in 3.4 release
+Notes

-Issue History
Date Modified Username Field Change
2013-12-10 17:41 Vincent Sanders New Issue
2013-12-10 17:41 Vincent Sanders Status new => assigned
2013-12-10 17:41 Vincent Sanders Assigned To => Sourceforge Import placeholder
2013-12-23 14:00 Vincent Sanders Assigned To Sourceforge Import placeholder => Steve Fryatt
2013-12-23 14:00 Vincent Sanders Reproducibility have not tried => N/A
2013-12-23 14:00 Vincent Sanders Status assigned => acknowledged
2013-12-23 14:00 Vincent Sanders Resolution no change required => open
2013-12-23 14:00 Vincent Sanders Category General => RISC OS-specific
2013-12-23 14:00 Vincent Sanders Description Updated View Revisions
2013-12-23 14:00 Vincent Sanders Additional Information Updated View Revisions
2014-02-09 16:29 Tony Moore Note Added: 0000196
2015-03-16 09:14 David Pitt Note Added: 0000774
2015-03-17 23:42 Vincent Sanders Fixed in CI build # => 2654
2015-03-17 23:42 Vincent Sanders Note Added: 0000786
2015-03-17 23:42 Vincent Sanders Assigned To Steve Fryatt => Vincent Sanders
2015-03-17 23:42 Vincent Sanders Status acknowledged => resolved
2015-03-17 23:42 Vincent Sanders Resolution open => fixed
2015-03-17 23:42 Vincent Sanders Fixed in Version => 3.4
2015-03-18 09:43 Rob Kendrick Note Added: 0000793
2015-03-18 10:31 Tony Moore Note Added: 0000795
2015-03-18 10:31 Tony Moore Status resolved => feedback
2015-03-18 10:31 Tony Moore Resolution fixed => reopened
2015-03-18 10:35 Tony Moore Note Edited: 0000795 View Revisions
2015-03-18 17:05 Vincent Sanders Status feedback => resolved
2015-03-18 17:05 Vincent Sanders Product Version => 1.0
2015-03-22 17:25 Vincent Sanders Resolution reopened => fixed
2016-02-16 15:30 Vincent Sanders Note Added: 0001323
2016-02-16 15:30 Vincent Sanders Status resolved => closed
+Issue History