2019-09-21 10:34 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001968NetSurfRISC OS-specificpublic2015-03-16 09:08
ReporterJohn Williams 
Assigned To 
SeverityfeatureReproducibilityN/A 
StatusacknowledgedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0001968: Add chkspr utility to Full Save
DescriptionA simple addition of the chkspr utility and a line in the Run file of full-save pseudo-applications would allow them to be renamed without losing the custom sprite that NetSurf has taken the trouble to create.

The utility, when invoked from the Run file, renames the first sprite in the sprite file to the name of the 'application'.

Thus it would not be essential to choose a suitable name instead of the default offered at initial save, but the pseudo-applications could be later renamed at will without losing the iconsprite.

Required:

    Include chkspr utility in app directory creation

    Add second line invoking "<Obey$Dir>.chkspr" to Run file


Additional Informationericthelog added a note on Mon Jul 9 19:49:16 2007

Logged In: YES
user_id=1768670
Originator: NO

Tony's Boot method /is/ superior, but I think the utility should be provided and referenced within the saved page application, as it would be unreasonable to expect everyone to have the utility in their library.

The full-saved page should be complete in its own right. Tony has agreed in principle to this suggestion.

old_coaster added a note on Sun Jul 8 11:58:58 2007

Logged In: YES
user_id=1384902
Originator: NO

A simpler way of doing this is to copy the _file_ ChkSpr (utility) to Boot:Library:User, and then add a Boot file to each NetSurf full-save pseudo-application. The Boot file need contain only:

   ifthere run:chkspr then chkspr
   iconsprites <obey$dir>.!sprites

An advantage of this is that the Boot file is executed immediately, upon renaming, so that the iconsprites command takes immediate effect.

If the Run file is modified, as suggested, it is necessary to open the full-save file before iconsprites takes effect.

Tony


Imported from sourceforge bug http://sourceforge.net/support/tracker.php?aid=1580902 on Tue Dec 10 17:34:13 2013

TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
David Pitt

~0000773

David Pitt (reporter)

This suggestion has not been implemented since 2007. However the "Full save" dialogue does allow for a user supplied "Save as" name which should be sufficient.

I would think this Issue can be closed.
+Notes

-Issue History
Date Modified Username Field Change
2013-12-10 17:41 Vincent Sanders New Issue
2013-12-10 17:41 Vincent Sanders Status new => assigned
2013-12-10 17:41 Vincent Sanders Assigned To => Sourceforge Import placeholder
2013-12-23 14:05 Vincent Sanders Assigned To Sourceforge Import placeholder =>
2013-12-23 14:05 Vincent Sanders Reproducibility have not tried => N/A
2013-12-23 14:05 Vincent Sanders Status assigned => acknowledged
2013-12-23 14:05 Vincent Sanders Resolution no change required => open
2013-12-23 14:05 Vincent Sanders Category General => RISC OS-specific
2013-12-23 14:05 Vincent Sanders Description Updated View Revisions
2013-12-23 14:05 Vincent Sanders Additional Information Updated View Revisions
2015-03-16 09:08 David Pitt Note Added: 0000773
+Issue History