2019-06-21 01:13 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000966NetSurf[All Projects] Generalpublic2006-07-11 01:41
Reportersclaes 
Assigned ToSourceforge Import placeholder 
SeverityminorReproducibilityhave not tried 
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000966: global history and encodings
Description
I have configured UTF8 as the current alphabet because it solves some problems. It enables me to use more than one charset: I can choose another keyboard driver to select chars from another charset. (I can even use this when I rename files or directories.) But there are still some problems...

If a title of a webpage is iso8859-9 encoded (latin5) and the title contains e.g. a dotlessi (\xFD) then an yacute is displayed instead of this dotlessi.
I can understand this because the yacute has the same code (\xFD). It is just a char form another char set (iso8859-1 aka latin1)

But if I enter a search string in Altavista (or Google) that contains a dotlessi then the resulting url is displayed incorrectly in the global history. The dotlessi is not replaced by an yacute (as expected) but as a ccedilla.

Why?

Additional Informationsclaes added a note on Tue Jul 11 13:25:24 2006

Logged In: YES
user_id=1055477

Is NS always sending 'Accept-charset: iso-8859-1' to the server?

BTW: why not add this to the choices file? (e.g. after the 'accept-language: ' entry)

sclaes added a note on Tue Jul 11 11:02:59 2006

Logged In: YES
user_id=1055477

NS doesn't use the current alphabet at all. :-(

I changed the alphabet to latin-5 and the configured country to turkey and I removed the obey file that changed the alphabet to UTF8. But when I go to
altavista.com, I still get the webpage in latin-1. Why?





sclaes added a note on Tue Jul 11 10:49:45 2006

Logged In: YES
user_id=1055477

Excellent.

There are still some problems with altavista though. For some reason altavista
insists on using latin-1 and it replaces the dotless i (in the search string) with
\x8f \xe7... I changed the preferred_language entry in the choices file but that didn't make any difference.

ICBW but I think NS doesn't use the current alphabet (on my computer it is changed to UTF8 by an obey file in !Boot.choices.boot.predesk) when requesting a webpage (from altavista). Is there any way to change this?

BTW: the title of a webpage is still displayed in latin-1 (instead of e.g. latin-5:
<http://www.osmanli.org.tr/>)



not_ginger_matt added a note on Tue Jul 11 01:41:17 2006

Logged In: YES
user_id=999199

Trees are now rendered using rufl rather than wimp_ploticon, thus should display UTF8 correctly.

Imported from sourceforge bug http://sourceforge.net/support/tracker.php?aid=1434430 on Tue Dec 10 17:34:12 2013

TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
There are no notes attached to this issue.
+Notes

-Issue History
Date Modified Username Field Change
2013-12-10 17:41 Vincent Sanders New Issue
2013-12-10 17:41 Vincent Sanders Assigned To => Sourceforge Import placeholder
+Issue History