2019-12-15 12:04 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000439NetSurf[All Projects] Generalpublic2014-02-09 23:37
ReporterRichard Porter 
Assigned To 
SeverityminorReproducibilityhave not tried 
StatusacknowledgedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0000439: Links in Framesets
DescriptionThe ability not to allow links to open in new windows (Choices > Content) is potentially very useful. Unfortunately it also seems to prevent links opening in the correct frame within framesets. The new page opens in the same pane as the link. Targets within the same window should always be observed.
Additional Informationnobody added a note on Mon Jul 27 13:42:09 2009

I think this problem was due to the web site. However it means that a page can potentially open in a very small navigation pane rather than the whole window. therefore if opening links in new windows is disabled, any links with "target="_new" or "target="_blank" should be treated as "target-_top".

Imported from sourceforge bug http://sourceforge.net/support/tracker.php?aid=2827764 on Tue Dec 10 17:34:12 2013

TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Richard Porter

~0000217

Richard Porter (reporter)

I think this still applies and therefore needs to be fixed, but framesets aren't as common as they hused to be and I have removed them from my sites.
+Notes

-Issue History
Date Modified Username Field Change
2013-12-10 17:41 Vincent Sanders New Issue
2013-12-10 17:41 Vincent Sanders Status new => assigned
2013-12-10 17:41 Vincent Sanders Assigned To => Sourceforge Import placeholder
2013-12-24 10:43 Vincent Sanders Assigned To Sourceforge Import placeholder =>
2013-12-24 10:43 Vincent Sanders Status assigned => acknowledged
2013-12-24 10:43 Vincent Sanders Resolution no change required => open
2013-12-24 10:43 Vincent Sanders Additional Information Updated View Revisions
2014-02-09 23:37 Richard Porter Note Added: 0000217
+Issue History