2019-01-16 17:24 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002566NetSurfRISC OS-specificpublic2018-08-29 14:03
ReporterPeter Young 
Assigned To 
SeveritycrashReproducibilityalways 
StatusclosedResolutionfixed 
PlatformRISC OSOS5OS Version5.23
Product Version3.7 
Target Version3.8Fixed in Version3.8 
Summary0002566: Repeatable crash on https://www.cheltenhamramblingclub.org.uk/leaders-information
DescriptionThis happened after a frest start-up of NetSurf. Navigate to the above pakge, and click to download oe of the .pdf files frpm the blank page which is usual in this circumstance. The download happens as exoected. Then use the back arrow to return to the page with the .pdf files and NetSurf immediately crashes.
Steps To ReproduceTye agai and it crashes again
TagsNo tags attached.
Fixed in CI build #4294
Reported in CI build #4233
URL of problem pagehttps://www.cheltenhamramblingclub.org.uk/leaders-information
Attached Files

-Relationships
+Relationships

-Notes
Peter Young

~0001679

Peter Young (reporter)

Sorry about the typing!
andreymal

~0001684

andreymal (reporter)

Linux GTK version also crashes with this URL. Last log line is:

content/content.c:277 content_convert: content https://cdn.website-start.de/s/img/1and1/logo.gif (0x556742d1b3a0)

http://2ip.ru also crashes on content_convert
andreymal

~0001685

andreymal (reporter)

Hm, looks like Linux GTK crash is another bug (or arch linux bug), sorry about flood
John-Mark Bell

~0001709

John-Mark Bell (administrator)

Fixed.
Vincent Sanders

~0001837

Vincent Sanders (administrator)

Thank you for your report, this has been resolved in the 3.8 release
+Notes

-Issue History
Date Modified Username Field Change
2017-10-22 15:10 Peter Young New Issue
2017-10-22 15:10 Peter Young File Added: Logfile.zip
2017-10-22 15:11 Peter Young Note Added: 0001679
2017-11-01 23:21 andreymal Note Added: 0001684
2017-11-01 23:34 andreymal Note Added: 0001685
2018-01-20 18:48 John-Mark Bell Status new => resolved
2018-01-20 18:48 John-Mark Bell Resolution open => fixed
2018-01-20 18:48 John-Mark Bell Product Version => 3.7
2018-01-20 18:48 John-Mark Bell Fixed in Version => 3.8
2018-01-20 18:48 John-Mark Bell Target Version => 3.8
2018-01-20 18:48 John-Mark Bell Fixed in CI build # => 4294
2018-01-20 18:48 John-Mark Bell Note Added: 0001709
2018-08-29 14:03 Vincent Sanders Status resolved => closed
2018-08-29 14:03 Vincent Sanders Note Added: 0001837
+Issue History