2023-03-22 16:24 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002494NetSurfRISC OS-specificpublic2017-01-13 22:09
ReporterDave Plowman 
Assigned ToDave Higton 
PlatformRPCOSRISC OSOS VersionRO 4.39
Product Version3.6 
Target VersionFixed in Version 
Summary0002494: Won'l run after fresh install/update.
DescriptionWas using an older version of NetSurf OK and updated to the latest one. Which won't run giving the error message "Application has gone wrong"
Steps To ReproduceTried downloading again, deleting the old and doing a fresh install. Same problem.
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
URL of problem page
Attached Files


Vincent Sanders


Vincent Sanders (administrator)

your log is from version 3.3 and appears to run ok.

Please can you ensure you install 3.6 and merge the system folder correctly.

If you still experience issues can you try the development images from http://ci.netsurf-browser.org/builds/riscos/ and attach the log from the failed run.

Rob Kendrick


Rob Kendrick (administrator)

Reporter emailed help@netsurf-browser.org with the following:

  I have installed 3.6 and it won't run at all, although 3.3 worked
normally. Hence asking for help - first on comp.sys.acorn.apps - and
being told to post to you with the log which as you say is probably from
when it last did run with the earlier version. Get the error:-

Internal Error: Undefined instruction at &00448154

Rob Kendrick


Rob Kendrick (administrator)

Dave, can you please describe the system you are using? What model of RiscPC, what CPU, etc?
Dave Plowman


Dave Plowman (reporter)

Last edited: 2016-12-31 15:04

View 2 revisions

It's an SA RPC600 running RO 4.39

Dave Higton


Dave Higton (developer)

Dave (Plowman): could you please answer these questions:

Please attach the (zipped) output of *modules

How much RAM does your machine have?

What other add-ons and applications are you running when you try to run a new NetSurf? For add-ons, I'm thinking of Minidisc, any keyboard add-ons...

Are you completely deleting the old !NetSurf application before copying the new one in?

Are you updating your !Boot and !System, using the Configure application, from those provided in the new archive?

Several people have confirmed that they are successfully running recent versions of NetSurf on Risc PCs (even today's CI version 3955 is reported as working), so it's something specific to your machine and/or the software running on it.

The failure you're seeing appears to be at a very early stage (maybe even while decompressing), before logging is started. I would be happy to email you a copy of NS with the binary uncompressed.
Dave Plowman


Dave Plowman (reporter)

Last edited: 2017-01-11 13:06

View 2 revisions

Tasks reports 129024K

Not running any add-ons I can think of. But I did try stopping all apps that load at boot with no difference.

I tried simply copying the new version over the old - and then deleting and trying afresh with a second new download.

I've installed sever versions over the years and knew about having to update Boot and System.

If it helps, my SA RPC has a Blitx card, a SCSI one, and the digital version of Viewfinder.

Dave Higton


Dave Higton (developer)

Dave P: can I send you an uncompressed RunImage file, to be used with CI #3955? If there is a problem during decompression of the normal binary, this should point up a difference.
Dave Higton


Dave Higton (developer)

Dave P: what version of the Viewfinder software are you running? The latest I can find on the official site is 1.78 (1 November 2011).

Also: are you able and willing to try running without the Viewfinder, to see if it makes any difference?
Dave Higton


Dave Higton (developer)

Last edited: 2017-01-12 20:58

View 3 revisions

I sent Dave Plowman two builds from my system, from #3956 sources, one with uncompressed binary and one compressed as normal. Both run OK.

We have another report of NetSurf failing to run on a Risc PC with Viewfinder. I have emailed the user a copy of the latter one that I sent to Dave Plowman.

I noticed that the binaries built on my system are of significantly different length to the official distros (in the region of 62 kB), so now the focus is on the tools and libraries.

Dave Higton


Dave Higton (developer)

Rob Kendrick noticed that the squeeze.c used within the NS build system is one revision behind:


The last change fixes an error related to squeezing modules, which may cause a heap corruption.
Dave Higton


Dave Higton (developer)

The build from my machine also works for the second person who reported the issue (Juergen).

-Issue History
Date Modified Username Field Change
2016-12-26 15:10 Dave Plowman New Issue
2016-12-26 15:10 Dave Plowman File Added: NetsurfLog.zip,ddc
2016-12-31 11:58 Vincent Sanders Note Added: 0001465
2016-12-31 11:58 Vincent Sanders Status new => feedback
2016-12-31 14:33 Rob Kendrick Note Added: 0001475
2016-12-31 14:33 Rob Kendrick Note Added: 0001476
2016-12-31 15:02 Dave Plowman Note Added: 0001477
2016-12-31 15:02 Dave Plowman Status feedback => new
2016-12-31 15:04 Dave Plowman Note Edited: 0001477 View Revisions
2017-01-10 17:21 Dave Higton Note Added: 0001485
2017-01-11 00:19 Vincent Sanders Status new => feedback
2017-01-11 13:01 Dave Plowman Note Added: 0001496
2017-01-11 13:01 Dave Plowman Status feedback => new
2017-01-11 13:03 Dave Plowman File Added: Modules.zip,ddc
2017-01-11 13:06 Dave Plowman Note Edited: 0001496 View Revisions
2017-01-11 19:58 Dave Higton Note Added: 0001497
2017-01-11 19:58 Dave Higton Assigned To => Dave Higton
2017-01-11 19:58 Dave Higton Status new => acknowledged
2017-01-11 20:29 Dave Higton Note Added: 0001498
2017-01-12 20:57 Dave Higton Note Added: 0001499
2017-01-12 20:57 Dave Higton Note Edited: 0001499 View Revisions
2017-01-12 20:58 Dave Higton Note Edited: 0001499 View Revisions
2017-01-12 21:03 Dave Higton Note Added: 0001500
2017-01-13 22:09 Dave Higton Note Added: 0001501
+Issue History