2024-03-03 19:15 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002371NetSurfJavascriptpublic2021-08-10 09:20
ReporterHarriet Bazley 
Assigned To 
PlatformARMOSRISC OSOS Version5.19
Product Version 
Target VersionFixed in Version 
Summary0002371: Browser doesn't stay logged in on Dreamwidth
DescriptionLogging in to an existing account on https://www.dreamwidth.org/ only allows access to your settings/account management pages - as soon as you navigate onto actual journals (including your own) the site treats you as not being logged in, and only public non-subscriber content is accessible. It's possible to post private content, but not to see it afterwards, and the options to subscribe to other journals/communities are always greyed out.
Steps To ReproduceI've created a test account to demonstrate this. Go to https://www.dreamwidth.org/login and log in as 'netsurf-test' (password 'RISC OS'). I've altered the settings so that all the management options are listed down the left-hand side of the page (by default they are on 'dynamic menus' not displayed by Netsurf).

Click on Read->Profile and you will see that two Journal Entries are displayed. Click on the 'Journal Entries' link (or just visit the home page at https://netsurf-test.dreamwidth.org/ ) and you will see only one, entitled "public journal entry". You will also see a box at the top of the page asking you to log in again - the site no longer recognises you as 'netsurf-test', which is why the second entry, set to be visible to the journal owner only, is not shown.

If you enter the journal's name and password into the log-in box you will find yourself back on the management pages again. Select Create->Edit Entries and you will see the private entry listed there, since the site recognises you as logged in when viewing these pages!

While logged in, visit any random journal - https://www.dreamwidth.org/random - and the options to subscribe/follow the journal which ought (I presume by analogy with the site's parent model, LiveJournal) to be present at the top of the page are replaced by the invitation to 'Create a Dreamwidth Account'.
The only way to subscribe to your friends' journals is to use manual codes via the Admin Console https://www.dreamwidth.org/admin/console/index - I've successfully subscribed this account to https://tigerfort.dreamwidth.org/profile (random account stating RISC OS as an interest) by that means.
Additional InformationIyonix Aria, RISC OS 5.20
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #3005
URL of problem pagehttps://netsurf-test.dreamwidth.org/
Attached Files


Harriet Bazley


Harriet Bazley (reporter)

This is still not working -- note that I've changed the log-in password to "RISC_OS" to meet the new requirements for Dreamwidth passwords.
Harriet Bazley


Harriet Bazley (reporter)

This is still ongoing - you can't view either your own private pages or those friends have set to private, and posting comments requires you to leave the 'From:' box blank. (screen1)
You will then get an error page reporting 'invalid form submission' in which you are both recognized as the current logged-in user and presented with a pre-filled log-in box with your username in it, requesting a password. (screen2)

If you delete the content of this writable icon you can then post the comment as 'logged-in account'...
Harriet Bazley


Harriet Bazley (reporter)

This is STILL ongoing - since the latest updates to Dreamwidth, the 'invalid form submission' page no longer allows you a second try at posting with your logged-in account, but just reports an error, effectively disabling the entire comment system and making it fairly useless as a bloggin platform.

It has been five years now; what is it about the Dreamwidth/LiveJournal codebase that disables NetSurf's ability to stay logged in to a website?
Harriet Bazley


Harriet Bazley (reporter)

It's not JavaScript-related, because if I disable JavaScript in OtterBrowser I still get the "post from logged-in account" option appearing (between OpenID and Dreamwidth account in the screenshots above). The problem in Netsurf is that the browser simply isn't registering as being logged in at this point, despite the fact that it *is* recognised as logged in for the purposes of actually making blogposts and reading notifications.

Enabling JavaScript in Netsurf doesn't help, although that's far from definitive....
Alexey Vazhnov


Alexey Vazhnov (reporter)

This problem is not RISC OS-specific: I have the same problem in Gentoo, netsurf-3.10-r4
Harriet Bazley


Harriet Bazley (reporter)

So as it's not a RISC OS issue and not a JavaScript issue, can it be recategorised at least?


Jenny (reporter)

This thread has been very helpful. Thank you! https://www.gulfcoastwebsitedesign.com/blog/responsive-vs-adaptive-website-design

-Issue History
Date Modified Username Field Change
2015-10-28 19:16 Harriet Bazley New Issue
2015-10-28 21:10 Vincent Sanders Status new => acknowledged
2015-10-28 21:10 Vincent Sanders Category General => Javascript
2015-10-28 21:10 Vincent Sanders Description Updated View Revisions
2015-10-28 21:10 Vincent Sanders Steps to Reproduce Updated View Revisions
2015-10-28 21:10 Vincent Sanders Additional Information Updated View Revisions
2016-11-14 03:00 Harriet Bazley Note Added: 0001415
2018-01-08 01:01 Harriet Bazley File Added: screen1.jpg
2018-01-08 01:01 Harriet Bazley Note Added: 0001702
2018-01-08 01:01 Harriet Bazley File Added: screen2.jpg
2020-06-29 23:57 Harriet Bazley Note Added: 0002269
2020-07-01 16:03 Harriet Bazley Note Added: 0002270
2021-01-03 13:00 Alexey Vazhnov Note Added: 0002320
2021-04-23 00:49 Harriet Bazley Note Added: 0002332
2021-08-10 09:20 Jenny Note Added: 0002346
+Issue History