2018-09-22 09:11 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002226NetSurfLayoutpublic2018-08-29 15:01
Reportereekee 
Assigned To 
SeveritymajorReproducibilityalways 
StatusclosedResolutionno change required 
PlatformOSLinuxOS Version
Product Version3.0 
Target VersionFixed in Version 
Summary0002226: can't build 3.0 -- libcss incompatible
Descriptioncss/css.c:781:6: error: too many arguments to function ?css_stylesheet_create?
In file included from /opt/netsurf/include/libcss/libcss.h:24:0,
                 from ./css/css.h:24,
                 from css/css.c:27:
/opt/netsurf/include/libcss/stylesheet.h:139:11: note: declared here
make: *** [build-Linux-gtk/css_css.o] Error 1

this is with nslibs obtained exactly as in netsurf-3.0/Docs/LIBRARIES.
could you perhaps provide version number or last-stable branches in the libs?
Steps To Reproducegit clone all the nslibs today (2014-11-21), build & install them.

attempt to build netscape 3.0 with:
export PREFIX=/opt/netsurf
export PKG_CONFIG_PATH=$PREFIX/lib/pkgconfig/
make -j4
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
There are no notes attached to this issue.
+Notes

-Issue History
Date Modified Username Field Change
2014-11-21 20:20 eekee New Issue
2014-12-01 14:39 Vincent Sanders Status new => acknowledged
2018-01-21 00:26 John-Mark Bell Status acknowledged => resolved
2018-01-21 00:26 John-Mark Bell Resolution open => no change required
2018-08-29 15:01 Vincent Sanders Status resolved => closed
+Issue History