2019-12-15 11:53 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001955NetSurf[All Projects] Generalpublic2013-12-23 13:39
Reportermittens 
Assigned To 
SeverityfeatureReproducibilityN/A 
StatusacknowledgedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0001955: Display 'alt' text for image upon mouse-over
DescriptionI would like Netsurf to display the 'alt' text for images (if any) when the mouse pointer lingers over them. I believe this behaviour is implemented by various other browsers (which is why I have come to expect it).

The simplest implementation would be to send an alternative reply to the HelpRequest messages sent by providers of interactive help. (Return the 'alt' text of an image instead of the standard "Click SELECT on a link to follow it.." help message.) I would be quite happy to load !Help in order to enable this facility, and this approach would automatically implement the user's preferred delay period and display font.

I don't think this would be a good use of the status bar because many images are also links, in which case the (usually half-width) status bar will already be full with the destination URI. Also descriptive 'alt' text would be too long.
Additional Informationdsalt added a note on Mon May 15 02:38:49 2006

Logged In: YES
user_id=294680

That would be "title attribute text", not "alt attribute
text" - the former is intended for display via mechanisms
such as tooltips, whereas the latter is a non-standard IEism.


Imported from sourceforge bug http://sourceforge.net/support/tracker.php?aid=1463118 on Tue Dec 10 17:34:13 2013

TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
There are no notes attached to this issue.
+Notes

-Issue History
Date Modified Username Field Change
2013-12-10 17:41 Vincent Sanders New Issue
2013-12-10 17:41 Vincent Sanders Status new => assigned
2013-12-10 17:41 Vincent Sanders Assigned To => Sourceforge Import placeholder
2013-12-23 13:39 Vincent Sanders Assigned To Sourceforge Import placeholder =>
2013-12-23 13:39 Vincent Sanders Reproducibility have not tried => N/A
2013-12-23 13:39 Vincent Sanders Status assigned => acknowledged
2013-12-23 13:39 Vincent Sanders Resolution no change required => open
2013-12-23 13:39 Vincent Sanders Description Updated View Revisions
2013-12-23 13:39 Vincent Sanders Additional Information Updated View Revisions
+Issue History