2017-10-22 03:44 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002493NetSurfAmiga-specificpublic2017-10-16 23:40
ReporterShy Nimtsan 
Assigned ToChris Young 
SeveritycrashReproducibilitysometimes 
StatusclosedResolutionunable to reproduce 
Product Version3.6 
Target VersionFixed in Version3.7 
Summary0002493: System "assert" crash on 2 separate occasions 0000002
DescriptionNothing special. Simply happens once i while and after latest update to 3.6 it happened twice in a couple of days. On this occasion it was when trying to drag from hotlist and drop at main window.
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Chris Young

~0001456

Chris Young (developer)

I'm unable to reproduce this, I've tried multiple drags from the hotlist to the main window in various directions, invalid and multiple selections.
Shy Nimtsan

~0001458

Shy Nimtsan (reporter)

Maybe the crash occurred a fraction before dnd. I said it's about that because that's what I was doing. It might be on an issue of selecting, the mouse hold loosening somewhat and then immediately selecting again in a fraction of a second. I use an old Logitech which has issue with its clicks sensitivity. this might stem from a competing condition when something occurs in a microsecond. Then it might also have more to do with the dragging part.
Chris Young

~0001461

Chris Young (developer)

This assert is:
    /* The node that we're moving selection to can't itself be selected */
    assert(!(relation->flags & TV_NFLAGS_SELECTED));

Whch makes sense as we're not moving it. I can only think that somehow NetSurf thinks you're dragging it within the hotlist window, but if that was the case the above assert wouldn't happen :S I can drag into the hotlist window borders and NetSurf is quite happy to move the item to where it thinks I want it.

If you can find a way of systematically reproducing it I'll have another look.
Chris Young

~0001481

Chris Young (developer)

The hotlist manager frontend and drag/drop code (especially to browser windows) is much changed now. Have a try with CI build 3954 and if you can't reproduce it I'll assume this is no longer an issue.
Vincent Sanders

~0001669

Vincent Sanders (administrator)

Thankyou for your report, this has been resolved in the 3.7 release
+Notes

-Issue History
Date Modified Username Field Change
2016-12-08 16:57 Shy Nimtsan New Issue
2016-12-08 16:57 Shy Nimtsan File Added: 20161208_174248.jpg
2016-12-10 00:15 Chris Young Note Added: 0001456
2016-12-10 00:15 Chris Young Assigned To => Chris Young
2016-12-10 00:15 Chris Young Status new => acknowledged
2016-12-10 16:52 Shy Nimtsan Note Added: 0001458
2016-12-11 17:31 Chris Young Note Added: 0001461
2016-12-11 17:31 Chris Young Status acknowledged => feedback
2017-01-08 23:20 Chris Young Note Added: 0001481
2017-03-30 00:16 Chris Young Status feedback => resolved
2017-03-30 00:16 Chris Young Fixed in Version => 3.7
2017-03-30 00:16 Chris Young Resolution open => unable to reproduce
2017-10-16 23:40 Vincent Sanders Status resolved => closed
2017-10-16 23:40 Vincent Sanders Note Added: 0001669
+Issue History