2019-03-26 21:20 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000521NetSurf[All Projects] Generalpublic2015-03-10 10:34
ReporterSourceforge Import placeholder 
Assigned ToMichael Drake 
SeverityminorReproducibilityhave not tried 
StatusclosedResolutionfixed 
Product Version3.0 
Target VersionFixed in Version3.1 
Summary0000521: Cookie deletion
Description(Copied from mailing list. Written from perspective of RISC OS; Chris Young confirms the jumping to bottom of list bug is core.)

Deleting cookies - any cookie - seems to be riddled with issues.

When I first select one and delete it (via the toolbar or the menu), the whole treeview flickers madly for a few seconds. After that, the cookie disappears from view, but scrolling down to the bottom reveals it's only been moved to the last entry instead of being deleted. Deleting it from its new position seems to work.

Deleting several cookies, either via the same delete operation or individually, results in them all being moved to the bottom. However, subsequently deleting one which was initially moved there but has since been pushed up by further deletions works, rather than moving it a few entries back to the bottom, so it doesn't seem to be a purely positional thing.
Additional InformationImported from sourceforge bug http://sourceforge.net/support/tracker.php?aid=3297709 on Tue Dec 10 17:34:12 2013

TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Vincent Sanders

~0000084

Vincent Sanders (administrator)

Treeview handling has been completely re-written. Is any of this still applicable?
Michael Drake

~0000089

Michael Drake (administrator)

All fixed by new treeview code.
Vincent Sanders

~0000648

Vincent Sanders (administrator)

Confirmed fixed in 3.1 release
+Notes

-Issue History
Date Modified Username Field Change
2013-12-10 17:41 Vincent Sanders New Issue
2013-12-10 17:41 Vincent Sanders Status new => assigned
2013-12-10 17:41 Vincent Sanders Assigned To => Sourceforge Import placeholder
2013-12-19 10:27 Vincent Sanders Note Added: 0000084
2013-12-19 10:27 Vincent Sanders Assigned To Sourceforge Import placeholder => Michael Drake
2013-12-19 10:27 Vincent Sanders Resolution no change required => open
2013-12-19 10:27 Vincent Sanders Product Version => 3.0
2013-12-19 10:27 Vincent Sanders Description Updated View Revisions
2013-12-19 10:27 Vincent Sanders Additional Information Updated View Revisions
2013-12-19 10:51 Michael Drake Note Added: 0000089
2013-12-19 10:51 Michael Drake Status assigned => resolved
2013-12-19 10:51 Michael Drake Fixed in Version => 3.1
2013-12-19 10:51 Michael Drake Resolution open => fixed
2015-03-10 10:34 Vincent Sanders Note Added: 0000648
2015-03-10 10:34 Vincent Sanders Status resolved => closed
+Issue History