2019-01-16 17:27 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000385NetSurfRISC OS-specificpublic2015-03-10 10:37
ReporterRoger Darlington 
Assigned ToSteve Fryatt 
SeveritymajorReproducibilityalways 
StatusclosedResolutionfixed 
PlatformOSRISC OSOS Version4.39
Product Version3.0 
Target VersionFixed in Version3.1 
Summary0000385: Mouse-Click in a frame, f8. This always loads the frameset p
DescriptionWhen using a framed website, and you click the mouse in one of the
frames, then press f8, it always puts the frame index file into the
editor, rather than the page belonging to the window you have just
pressed the mouse in.

This works properly in NS dev vers r12638 (and many others of this
period)


Additional InformationImported from sourceforge bug http://sourceforge.net/support/tracker.php?aid=3613392 on Tue Dec 10 17:34:12 2013

TagsNo tags attached.
Fixed in CI build #1566
Reported in CI build #
URL of problem pagehttp://wildflowerfinder.org.uk/
Attached Files

-Relationships
+Relationships

-Notes
Vincent Sanders

~0000019

Vincent Sanders (administrator)

Please can you confirm the operating system, platform and version of netsurf (released or development) you encounter this issue with?
Vincent Sanders

~0000021

Vincent Sanders (administrator)

Roger Darlington via email

It does not work in many Netsurfs beyond those of the era r12638, which is the version I am forced to use now, since all other Netsurfs produced since then, exhibit this MAJOR problem (not minor as you claim). I always need to use f8 to see the contents in the selected frame. I never need not to, so all other Netsurfs are useless to me until this bug is fixed again... [You fixed it once, well before 2011, but broke it again in later versions]

So, any Netsurfs produced after 2012, including Netsurf 3.00 (checked and proved) exhibit this problem (but I have not checked the latesttest build, but unless you have done something to fix it, I reckon that this bug is still extant in the latest test dev.

I am using Netsurf on RISC OS (RO 4.39) emulator of RISC OS - but that need not concern you - version r12638 works properly - so the computer doing the emulation has nothing to do with the problem].
Steve Fryatt

~0000140

Steve Fryatt (developer)

F8 now returns source for frame under pointer, if possible; else parent frameset.

Behaviour of Page, View Source in menu is unchanged.
Vincent Sanders

~0000658

Vincent Sanders (administrator)

Confirmed fixed in 3.1 release
+Notes

-Issue History
Date Modified Username Field Change
2013-12-10 17:41 Vincent Sanders New Issue
2013-12-10 17:41 Vincent Sanders Status new => assigned
2013-12-10 17:41 Vincent Sanders Assigned To => Sourceforge Import placeholder
2013-12-16 12:02 Vincent Sanders URL of problem page => http://wildflowerfinder.org.uk/
2013-12-16 12:02 Vincent Sanders Assigned To Sourceforge Import placeholder =>
2013-12-16 12:02 Vincent Sanders Description Updated View Revisions
2013-12-16 12:02 Vincent Sanders Additional Information Updated View Revisions
2013-12-16 12:12 Vincent Sanders Note Added: 0000019
2013-12-16 12:12 Vincent Sanders Status assigned => feedback
2013-12-16 12:12 Vincent Sanders Description Updated View Revisions
2013-12-17 13:30 Vincent Sanders Note Added: 0000021
2013-12-17 13:30 Vincent Sanders Severity minor => major
2013-12-17 13:30 Vincent Sanders Reproducibility have not tried => always
2013-12-17 13:30 Vincent Sanders Status feedback => confirmed
2013-12-17 13:30 Vincent Sanders Resolution no change required => open
2013-12-17 13:30 Vincent Sanders OS => RISC OS
2013-12-17 13:30 Vincent Sanders OS Version => 4.39
2013-12-17 13:30 Vincent Sanders Product Version => 3.0
2013-12-17 13:31 Vincent Sanders Category General => RISC OS-specific
2013-12-18 22:36 Vincent Sanders Assigned To => Steve Fryatt
2013-12-18 22:36 Vincent Sanders Status confirmed => assigned
2014-01-02 22:57 Steve Fryatt Fixed in CI build # => 1566
2014-01-02 22:57 Steve Fryatt Note Added: 0000140
2014-01-02 22:57 Steve Fryatt Status assigned => resolved
2014-01-02 22:57 Steve Fryatt Resolution open => fixed
2014-01-02 23:16 Vincent Sanders Fixed in Version => 3.1
2015-03-10 10:37 Vincent Sanders Note Added: 0000658
2015-03-10 10:37 Vincent Sanders Status resolved => closed
+Issue History