2019-06-25 03:24 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002315NetSurfRISC OS-specificpublic2016-02-16 15:29
ReporterRichard Porter 
Assigned ToVincent Sanders 
SeveritycrashReproducibilitysometimes 
StatusclosedResolutionfixed 
PlatformRiscPCOSRISC OSOS Version6.16
Product Version3.4 
Target Version3.4Fixed in Version3.4 
Summary0002315: Segmentation Fault
DescriptionNS crashed with a "serious error". I was scrolling down the page while images were still loading,
Steps To ReproduceGo to problem page. After first one or two photos have downloaded scroll down and up while remaining photos are still loading.
TagsNo tags attached.
Fixed in CI build #2775
Reported in CI build #2772
URL of problem pagehttp://maximummini.blogspot.com/2015/05/looking-back-at-blyton-park-2015-2.html
Attached Files

-Relationships
+Relationships

-Notes
Vincent Sanders

~0000846

Vincent Sanders (administrator)

The issue was caused by the PNG image handler not coping with low memory situations. Now fixed
Vincent Sanders

~0001317

Vincent Sanders (administrator)

Confirmed resolved in 3.4 release
+Notes

-Issue History
Date Modified Username Field Change
2015-05-08 12:21 Richard Porter New Issue
2015-05-08 12:21 Richard Porter File Added: nslog315.zip
2015-05-12 08:53 Vincent Sanders Fixed in CI build # => 2775
2015-05-12 08:53 Vincent Sanders Note Added: 0000846
2015-05-12 08:53 Vincent Sanders Assigned To => Vincent Sanders
2015-05-12 08:53 Vincent Sanders Reproducibility have not tried => sometimes
2015-05-12 08:53 Vincent Sanders Status new => resolved
2015-05-12 08:53 Vincent Sanders Resolution open => fixed
2015-05-12 08:53 Vincent Sanders Product Version => 3.4
2015-05-12 08:53 Vincent Sanders Fixed in Version => 3.4
2015-05-12 08:53 Vincent Sanders Target Version => 3.4
2016-02-16 15:29 Vincent Sanders Note Added: 0001317
2016-02-16 15:29 Vincent Sanders Status resolved => closed
+Issue History