2019-05-26 22:49 BST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001989NetSurf[All Projects] Generalpublic2015-03-10 10:39
Reporterdruck 
Assigned ToVincent Sanders 
SeverityfeatureReproducibilityhave not tried 
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0 
Summary0001989: Clear a text area
DescriptionThe ability to clear an entire multiline text area with a key shortcut.

Completely removing large amounts of text from a text area is very difficult. Ctrl+U only deletes one line, and it seems impossible to either make a selection larger than the visible text with the mouse, ctrl+A often selects the entire page, and ctrl+X fails to delete.
 
All that needs fixing, but a shortcut would be a workaround and a useful feature in itself.
Additional Informationdruck added a note on Tue Feb 5 23:18:10 2008

Try that on a large area and see how long it takes.

What prompted this report was an attempt to edit this RISC OS Opebn wiki page http://www.riscosopen.org/wiki/documentation/pages/FilingSystemUpdate
I exported the text to Zap, edited it, then was faced with the task of clearing the field before I could past back in to it. It took about 5 minutes.

A better solution is required.

nobody added a note on Tue Feb 5 22:26:27 2008

What about Ctrl-End + auto-repeat?

Imported from sourceforge bug http://sourceforge.net/support/tracker.php?aid=1884937 on Tue Dec 10 17:34:13 2013
TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
URL of problem page
Attached Files

-Relationships
+Relationships

-Notes
Vincent Sanders

~0000132

Vincent Sanders (administrator)

Text area handling was completely re-written since this report was submitted, is this issue still reproducible?
Michael Drake

~0000157

Michael Drake (administrator)

Ctrl+A, Ctrl+X works with new textarea.
Vincent Sanders

~0000668

Vincent Sanders (administrator)

Confirmed fixed in 3.0 release
+Notes

-Issue History
Date Modified Username Field Change
2013-12-10 17:41 Vincent Sanders New Issue
2013-12-10 17:41 Vincent Sanders Status new => assigned
2013-12-10 17:41 Vincent Sanders Assigned To => Sourceforge Import placeholder
2013-12-24 14:18 Vincent Sanders Note Added: 0000132
2013-12-24 14:18 Vincent Sanders Assigned To Sourceforge Import placeholder =>
2013-12-24 14:18 Vincent Sanders Status assigned => feedback
2013-12-24 14:18 Vincent Sanders Resolution no change required => open
2013-12-24 14:18 Vincent Sanders Description Updated View Revisions
2013-12-24 14:18 Vincent Sanders Additional Information Updated View Revisions
2014-01-06 23:15 Michael Drake Note Added: 0000157
2014-01-06 23:15 Michael Drake Status feedback => resolved
2014-01-06 23:15 Michael Drake Resolution open => fixed
2014-01-06 23:15 Michael Drake Fixed in Version => 3.0
2015-03-10 10:39 Vincent Sanders Note Added: 0000668
2015-03-10 10:39 Vincent Sanders Status resolved => closed
2015-03-10 10:39 Vincent Sanders Assigned To => Vincent Sanders
+Issue History