2019-12-11 04:36 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001884NetSurf[All Projects] Generalpublic2016-11-22 21:59
ReporterJames Le Cuirot 
Assigned To 
SeverityfeatureReproducibilityhave not tried 
StatusclosedResolutionfixed 
Product Version 
Target VersionFixed in Version3.6 
Summary0001884: Conditionally include image headers
DescriptionHere's a patch that conditionally include image headers to allow building without some dependencies present, such as libnsbmp. Without this, it complains that libnsbmp.h is missing.
Additional InformationImported from sourceforge bug http://sourceforge.net/support/tracker.php?aid=3559268 on Tue Dec 10 17:34:13 2013

TagsNo tags attached.
Fixed in CI build #
Reported in CI build #
URL of problem page
Attached Files
  • patch file icon netsurf-2.9-conditionally-include-image-headers.patch (1,182 bytes) 2013-12-20 12:15 -
    From 7abd1c708d894a67617e60c2f85d6db355a713bb Mon Sep 17 00:00:00 2001
    From: James Le Cuirot <chewi@aura-online.co.uk>
    Date: Sat, 18 Aug 2012 16:10:23 +0100
    Subject: [PATCH] Conditionally include image headers to allow building
     without some dependencies.
    
    ---
     image/image.c |   32 +++++++++++++++++++++++++++++---
     1 files changed, 29 insertions(+), 3 deletions(-)
    
    diff --git a/image/image.c b/image/image.c
    index becf221..70b981b 100644
    --- a/image/image.c
    +++ b/image/image.c
    @@ -27,16 +27,42 @@
     #include "desktop/plotters.h"
     #include "image/bitmap.h"
     
    +#ifdef WITH_BMP
     #include "image/bmp.h"
    -#include "image/gif.h"
     #include "image/ico.h"
    +#endif
    +
    +#ifdef WITH_GIF
    +#include "image/gif.h"
    +#endif
    +
    +#ifdef WITH_JPEG
     #include "image/jpeg.h"
    +#endif
    +
    +#ifdef WITH_MNG
     #include "image/mng.h"
    -#include "image/nssprite.h"
    +#endif
    +
    +#ifdef WITH_PNG
     #include "image/png.h"
    -#include "image/rsvg.h"
    +#endif
    +
    +#ifdef WITH_NSSPRITE
    +#include "image/nssprite.h"
    +#endif
    +
    +#ifdef WITH_NS_SVG
     #include "image/svg.h"
    +#endif
    +
    +#ifdef WITH_RSVG
    +#include "image/rsvg.h"
    +#endif
    +
    +#ifdef WITH_WEBP
     #include "image/webp.h"
    +#endif
     
     #include "image/image.h"
     
    -- 
    1.7.8.6
    
    

-Relationships
+Relationships

-Notes
Vincent Sanders

~0000093

Vincent Sanders (administrator)

NetSurf build system needs to make the image libs optional is what this was asking. We dropped the patch on the floor in the sourceforge move though.
James Le Cuirot

~0000094

James Le Cuirot (reporter)

Last edited: 2013-12-20 12:16

View 2 revisions

Here is the patch. It still appears to be necessary. Makefile.config allows you to disable certain image formats but this doesn't work in practise without this patch. For example, if you disable BMP support, image/bmp.h will include libnsbmp.h anyway when it might not be present. Here is a failed build log from Gentoo Linux.

https://tinderboxlogs.s3.amazonaws.com/tbamd64.excelsior.flameeyes.eu/www-client%3Anetsurf-2.9%3A20120730-113505.html

Note that I haven't tested against the latest version as I don't use NetSurf any more.

Vincent Sanders

~0001389

Vincent Sanders (administrator)

NETSURF_USE_BMP := NO
in Makefile.config now works as does disabling any of teh supported image handlers
Vincent Sanders

~0001429

Vincent Sanders (administrator)

this issue has been closed because it is included in the 3.6 release
+Notes

-Issue History
Date Modified Username Field Change
2013-12-10 17:41 Vincent Sanders New Issue
2013-12-10 17:41 Vincent Sanders Status new => assigned
2013-12-10 17:41 Vincent Sanders Assigned To => Sourceforge Import placeholder
2013-12-20 11:49 Vincent Sanders Note Added: 0000093
2013-12-20 11:49 Vincent Sanders Assigned To Sourceforge Import placeholder =>
2013-12-20 11:49 Vincent Sanders Severity minor => feature
2013-12-20 11:49 Vincent Sanders Status assigned => acknowledged
2013-12-20 11:49 Vincent Sanders Resolution no change required => open
2013-12-20 11:49 Vincent Sanders Additional Information Updated View Revisions
2013-12-20 12:15 James Le Cuirot Note Added: 0000094
2013-12-20 12:15 James Le Cuirot File Added: netsurf-2.9-conditionally-include-image-headers.patch
2013-12-20 12:16 James Le Cuirot Note Edited: 0000094 View Revisions
2016-08-14 23:05 Vincent Sanders Note Added: 0001389
2016-08-14 23:05 Vincent Sanders Status acknowledged => resolved
2016-08-14 23:05 Vincent Sanders Resolution open => fixed
2016-08-14 23:05 Vincent Sanders Fixed in Version => 3.6
2016-11-22 21:59 Vincent Sanders Note Added: 0001429
2016-11-22 21:59 Vincent Sanders Status resolved => closed
+Issue History