MantisBT - NetSurf
View Issue Details
0002628NetSurfFramebuffer-specificpublic2018-11-14 10:362019-02-16 09:01
ReporterLonnie Cumberland 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionduplicate 
PlatformLinuxOSUbuntuOS Version18.04
Product Version3.8 
Target VersionFixed in Version 
Fixed in CI build #
Reported in CI build #
URL of problem page
Summary0002628: running nsfb always give error
DescriptionHello,

I have been following the build instructions for the netsurf which compiles and even runs the nsgtk with no problems, but when I compile and run the nsfb I get and error:

~/dev-netsurf/workspace/netsurf$ ./nsfb
Message translations failed to load
Unable to initialise framebuffer

Steps To ReproduceTo reproduce this, I followed:

https://ci.netsurf-browser.org/jenkins/job/docs-netsurf/doxygen/md_docs_quick-start.html

To build the framebuffer front end, you could do:

  $ make TARGET=framebuffer
  $ ./nsfb
Additional InformationAlso followed:

https://github.com/pcwalton/NetSurf/blob/master/netsurf/Docs/BUILDING-Framebuffer
TagsNo tags attached.
duplicate of 0002616resolved Vincent Sanders netsurf-fb warns about missing Messages 
Attached Files

Notes
(0001875)
Vincent Sanders   
2019-02-16 09:01   
duplicate of 2616 will be addressed there

Issue History
2018-11-14 10:36Lonnie CumberlandNew Issue
2019-02-16 09:00Vincent SandersRelationship addedduplicate of 0002616
2019-02-16 09:01Vincent SandersStatusnew => closed
2019-02-16 09:01Vincent SandersResolutionopen => duplicate
2019-02-16 09:01Vincent SandersNote Added: 0001875