MantisBT - Buildsystem
View Issue Details
0002311Buildsystem[All Projects] Generalpublic2015-04-29 09:522018-04-21 08:16
ReporterLeon Stringer 
Assigned ToDaniel Silverstone 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusresolvedResolutionfixed 
PlatformCentOS 7OSLinuxOS Version
Fixed in CI build #
Reported in CI build #
Summary0002311: Package gperf dependency to build on CentOS 7
DescriptionI followed the instructions in http://source.netsurf-browser.org/netsurf.git/plain/Docs/QUICK-START to get NetSurf running. This worked except the first build attempt (ns-pull-install) failed with:

ake: Entering directory `/home/leon/dev-netsurf/workspace/libsvgtiny'
   GPERF: src/colors.gperf
make: gperf: Command not found
make: *** No rule to make target `build-x86_64-redhat-linux-x86_64-redhat-linux-release-lib-static/src_colors.c', needed by `build-x86_64-redhat-linux-x86_64-redhat-linux-release-lib-static/build-x86_64-redhat-linux-x86_64-redhat-linux-release-lib-static_src_colors.o'. Stop.
make: Leaving directory `/home/leon/dev-netsurf/workspace/libsvgtiny'

I had to install standard package 'gperf' and then it worked.
TagsNo tags attached.
Attached Files

Notes
(0001752)
Daniel Silverstone   
2018-04-21 08:16   
env.sh has been updated to include gperf for YUM dependencies in commit 911467d

Issue History
2015-04-29 09:52Leon StringerNew Issue
2018-04-21 08:16Daniel SilverstoneAssigned To => Daniel Silverstone
2018-04-21 08:16Daniel SilverstoneStatusnew => resolved
2018-04-21 08:16Daniel SilverstoneResolutionopen => fixed
2018-04-21 08:16Daniel SilverstoneDescription Updatedbug_revision_view_page.php?rev_id=1999#r1999
2018-04-21 08:16Daniel SilverstoneNote Added: 0001752